Home > Could Not > Could Not Create Makefile Due To Some Reason

Could Not Create Makefile Due To Some Reason

Contents

In it, you'll get: The week's top questions and answers Important community announcements Questions that need answers see an example newsletter By subscribing, you agree to the privacy policy and terms regex December 12, 2012, 1:31 pm thank you 😀 DoctorRu June 4, 2013, 10:12 am Thks a lot! no checking for main() in -lnsl... If you look in the sqlite-autoconf-3080803 folder you will see that there is no file with that name there. http://jessriegel.com/could-not/joomla-could-not-create-directory-unable-to-create-destination.html

Check the mkmf.log file for more details. Building native extensions. ERROR: Error installing nokogiri: ERROR: Failed to build gem native extension. I wish I could give 100 upvotes! –Tᴀʀᴇǫ Mᴀʜᴍᴏᴏᴅ yesterday add a comment| up vote 2 down vote My mkmf.log showed that gcc (4.8.2 I think) didn't like a specific argument http://stackoverflow.com/questions/19697359/ruby-debug-could-not-create-makefile-due-to-some-reason-probably-lack-of-necess

Could Not Create Makefile Due To Some Reason Windows

If not, you can use sudo find / -name mkmf.log to find it. Check the mkmf.log file for more details. Error: ➜ Vendor git:(master) ✗ sudo gem install ffi Building native extensions. no *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers.

please visit http://nokogiri.org/tutorials/installing_nokogiri.html for help with installing dependencies. ----- *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. kalvinmanson October 15, 2013, 5:00 pm How i can do this on Windows? Employer offering Roth 401k as well as traditional 401(k), established in career Would presence of MANPADS ground the entire airline industry? Mkmf.log Windows Error: failed to builed gem native extension1Error when installing Rails on Ubuntu 141Ruby on Rails install on Amazon AWS fails: Could not create Makefile due to some reason, probably lack of

Check the mkmf.log file for more details. Package Configuration For Libffi Is Not Found Your Linux installation requires that the development libraries for MySQL to be installed in order to build the gem. Pre-requisite: Having MYSQL installed. current directory: /Users/username/.rbenv/versions/2.0.0-p481/lib/ruby/gems/2.0.0/gems/nokogiri-1.6.6.4/ext/nokogiri /Users/username/.rbenv/versions/2.0.0-p481/bin/ruby -r ./siteconf20151127-29540-11ahx4h.rb extconf.rb checking if the C compiler accepts ... *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries

Another error! Error Installing Mysql: Error: Failed To Build Gem Native Extension. Word for fake religious people Output the first position in your program for each input character Get out of the transit airport at Schengen area and the counting of Schengen period ERROR: Error installing mysql: ERROR: Failed to build gem native extension. /usr/bin/ruby1.8 extconf.rb checking for mysql_query() in -lmysqlclient... why do they give the same output?

Package Configuration For Libffi Is Not Found

Re-installation of ruby should be a better fix in this case. https://www.question-defense.com/2010/02/23/error-error-installing-webrat-could-not-create-makefile-due-to-some-reason-probably-lack-of-necessary-libraries-andor-headers rdoc (4.2.0) sqlite3 (1.3.10) test-unit (3.0.8) Finally Rubygems see our newly built sqlite3 gem. Could Not Create Makefile Due To Some Reason Windows but when we try to install mysql gem running in to problems saying below msg. Could Not Create Makefile Due To Some Reason Nokogiri Powered by Redmine © 2006-2014 Jean-Philippe Lang

Does this ring a bell? this contact form Devkit Installing Native Gems From Headers And Shared Libraries HeatWare.net TwitterRSSEmail Submit Search Home Windows Windows 8 Windows 7 Windows Vista Windows XP Linux/Unix Mac Mobile Android iOS Phones (Help / yes checking for cmake... holgersindbaek commented Oct 14, 2013 After a lot of messing around, I ended up messing around with brew. Could Not Create Makefile Due To Some Reason Mysql2

Moreover Visual Studio was commercial and not all of Ruby developers had it. skibum55 Answer Email {} Share The error is in the mkmf.log file. This could take a while... ERROR: Error installing nokogiri: ERROR: Failed to build gem native extension. /home/novalagung/.rvm/rubies/ruby-2.0.0-p247/bin/ruby extconf.rb checking for libxml/parser.h... have a peek here yes checking for mysql_query() in -lmysqlclient...

ERROR: Error installing ffi: ERROR: Failed to build gem native extension. /Users/holgersindbaek/.rvm/rubies/ruby-1.9.3-p448/bin/ruby extconf.rb checking for ffi.h... *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of Extconf.rb Failed Windows For me, there's mkmf.log files for many other gems but not the one that's having a problem. –levininja Aug 18 at 21:46 @levininja did you get any extra info rdoc (4.1.0) test-unit (2.1.5.0) It might be surprising that sqlite3 gem isn't in the list, but what we did is just one step performed

Get out of the transit airport at Schengen area and the counting of Schengen period Why do Latin nouns (like cena, -ae) include two forms?

That file should be located at /home/hxh/.rvm/gems/ruby-1.9.3-p448/gems/linecache-0.46/ext/linecache/mkmf.log. Still getting the exact same error message. –Nappstir Nov 28 '15 at 6:04 1 Have you accepted the license agreement? After extracting, our sqlite3.h file will be in the sqlite-autoconf-3080803 directory and full path to it is exactly what we have to pass to the configuration script. Fatal Error: 'ruby/config.h' File Not Found Thank you very much and appreciate your time on this request.

I followed these steps below for installing rails: sudo apt-get install ruby-full sudo apt-get install libz-dev libiconv-hook1 libiconv-hook-dev sudo gem install rails share|improve this answer answered Nov 13 at 3:03 heronsanches Is ATC communication subject to FCC profanity regulations? Can you make anything out of that? Check This Out RubyInstaller project has changed a lot in that field.

Copy it to the the C:\tools folder and try to load gem in irb: irb(main):002:0> require 'sqlite3' => true irb(main):003:0> We successfully built not I had some errors with MySql installation but they were mainly related to file / folder permissions.Also see what /etc/my.cnf file is having. Now you may be thinking I was installing webrat so who cares about the nokogiri gem but the reality is that webrat requires the nokogiri gem so if this fails then Reload to refresh your session.