Home > Gentoo Could > Gentoo Could Not Run/locate I686-pc-linux-gnu-gcc

Gentoo Could Not Run/locate I686-pc-linux-gnu-gcc

You can try editing that file if you don't want to recomplile xorg-xll.Zac--gentoo-***@gentoo.org mailing list 7 Replies 5 Views Switch to linear view Disable enhanced parsing Permalink to this page Thread Ich hätte schwören können das ich es Heute Morgen probiert hatte aber da habe ich mich wohl vertan. Running gcc-config myself # gcc-config -l, I get back this error message: * gcc-config: Active gcc profile is invalid! [1] x86_64-pc-linux-gnu-4.4.5 . 4.4.5 is indeed the version of my gcc package. There have been severalthreads discussing this problem. Check This Out

The error should be gone now.Thanks for that. There are also predefined macros as __DATE__ and __TIME__ that hold date and time when the compilation run. I suspect the onethere is just a wrapper (but not a script) to more stuff, because theexecutable is rather small. There might be more files than just those two. https://forums.gentoo.org/viewtopic-t-321340.html

Macros are written in uppercase. Check the directory /etc/env.d/gcc***@sebb sbraun $ ls /etc/env.d/gcc/config i686-pc-linux-gnu-3.3.22. Running gcc-config myself > > # gcc-config -l, I get back this error message: > > * gcc-config: Active gcc profile is invalid! > > [1] x86_64-pc-linux-gnu-4.4.5 > > . 4.4.5 The error just means gcc-config didn't get run properly before uninstalling your previous version of gcc.

i686-pc-linux-gnu-gcc checking for C compiler default output file name... Where can I find it, and what do I need to do > to make it valid? > gcc-config 1 Attachments: signature.asc (0.26 KB) kutulu at kutulu Apr27,2011,7:03AM Post #4 of 5 (3235 This got updated very > recently. > > What is a "gcc profile"? Sure enough, I got the same error.

Portage version?#gcc-config i686-pc-linux-gnu-3.3.5it gives me no error.But the error I wrote in 1st mail still remains...askarhttp://forums.gentoo.org/viewtopic-t-230783.htmlIt mentions both the python-fchksum and groff errors. I fixed that and I now getCould not run/locate "gcc".However, ls -l /etc/bin/gcc shows that it is there. Running gcc-config myself > # gcc-config -l, I get back this error message: > > * gcc-config: Active gcc profile is invalid! > [1] x86_64-pc-linux-gnu-4.4.5 > > . 4.4.5 is indeed http://www.gossamer-threads.com/lists/gentoo/user/229560 Binaries compiled with different compiler versions can (but do not have to) create incompatibility problems (mainly libraries).

The important clues: configure: error: C compiler cannot create executables The complete build log is located at ‘/var/tmp/portage/app-editors/nano-2.3.1-r2/temp/build.log'. Re: gcc-config: error: could not run/locate 'gcc' « Відповідей #4 : 2009-08-14 12:16:14 » Цитата ЦитатаМожете спробуватиgcc-config i686-pc-linux-gnu-4.3.2Робив, нуль ефекту.Який файл кажете? Записаний yurchor Видавець Відсутній дописів: 3394 Grateful for our The vanilla solution to this problem is1. This got updated very > recently. > > What is a "gcc profile"?

Index | Next | Previous | Print Thread | View Threaded Gentoo Alpha AMD64 Announce Desktop Dev Doc Embedded GWN Hardened HPPA MIPS OSX Performance PPC-Dev PPC-User Security SPARC http://gentoo-user.gentoo.narkive.com/i6np6Bsu/gcc-config-error-could-not-run-locate-i386-pc-linux-gnu-gcc Select the one(besides config) which matches your needs, this generally is-, in the example above i686-pc-linux-gnu-3.3.23. Pass it to gcc-config as its only option* Switching to i686-pc-linux-gnu-3.3.2 compiler... [ ok ]4. Don’t skip around–you definitely want to run the ‘emerge -avNDu @world’ prior to a depclean: 1 2 # --depclean (-c), Cleans the system by removing packages that are not

motya Новачок Відсутній дописів: 33 I Love YaBB 2! his comment is here Re: gcc-config: error: could not run/locate 'gcc' « Відповідей #8 : 2009-08-14 13:55:29 » Цитата Та і на тому дякую!Буду поки-що під рутом компілювати... ех.... « Змінено: 2009-08-14 13:56:01 від motya Often people you use gcc as a synonym for the c compiler, consider this a the default compiler. I suspect the onethere is just a wrapper (but not a script) to more stuff, because theexecutable is rather small.

other terminals also. [ ... ] CBUILD="i686-pc-linux-gnu" CFLAGS="-O2 -march=pentium4m" CHOST="i686-pc-linux-gnu" CXXFLAGS="-O2 -march=pentium4m" [ ... ] Vollständiges emerge --info hier. !!! Sure enough, I got the same error. Check the directory /etc/env.d/gccconfig i686-pc-linux-gnu-3.3.22. this contact form Gcc uses the preprocessor (cpp), the C compiler (cc), the Gnu assembler (as) and the Gnu linker (ld).

I got the error message gcc-config: error: could not run/locate 'x86_64-pc-linux-gnu-gcc' whilst trying to emerge something. regardless of ABI during linking526686 : sys-devel/gcc: only gcc/doc/ info pages are installed from gcc/ which misses gfortran526926 : sys-devel/gcc-4.8.3 miscompiles =app-arch/tar-1.27.1-r2 built with -ftree-vectorize - tar: Skipping to next header526986 Finally, I decided to run a ‘–depclean’, to remove packages that are not associated with explicitly merged packages.

This has been, in fact, thoroughly discussed on the Gentoo bugzilla.

I'm guessing but maybe you can edit /usr/lib/X11/config/host.def to fix this one. [email protected] Discussion: Could not run/locate "gcc" (too old to reply) Fred Labrosse 2004-03-26 10:46:33 UTC PermalinkRaw Message All,I'm currently in the process of upgrading a machine that had not beeupgraded since The preprocessor could also be run standalone. #define BUFFER 32 assigns the number 32 to the word (or in terms of cpp the macro) BUFFER. Does it say #define CcCmd i386-pc-linux-gnu-gcc in there?ZacI was curious if I could reproduce your problem so I edited /usr/lib/X11/config/host.def and changed it to #define CcCmd i386-pc-linux-gnu-gcc.

Does it say #define CcCmd i386-pc-linux-gnu-gcc in there?Zac--gentoo-***@gentoo.org mailing list Zac Medico 2005-06-12 10:06:06 UTC PermalinkRaw Message Post by Zac MedicoPost by askar ...Post by Ted OzolinsPost by askar ...gcc-config error: Mittag, folgendes Problem beim emergen beliebiger Software: Quellcode 1 2 3 4 checking for i686-pc-linux-gnu-gcc... Sure enough, I got the same error. navigate here Running gcc-config myself > # gcc-config -l, I get back this error message: > > * gcc-config: Active gcc profile is invalid! > [1] x86_64-pc-linux-gnu-4.4.5 > > . 4.4.5 is indeed