Home > Maindeployer Could > Maindeployer Could Not Initialise

Maindeployer Could Not Initialise

to my understanding i did everything needed to compile and start jboss 4.2.3. for the multiple url tag, I think it's because of this : Code: Persistent Faces Servlet *.iface *.jspx /xmlhttp/* /faces/* in my web.xml. Re: Error Could not initialise deployment jbossws.sar on run jaikiran pai Sep 15, 2008 6:04 AM (in response to Shailesh Tyagi) Okay, now that you have tried the possible options and I have 60GB of available disk space (this is a test installation). this content

And then suddenly everything went south and we’re writing code… 4 days ago Twitter Facebook Google Plus Follow us on social media 01 Dec Webclipse CI 9 is out, and with All rights reserved. 2221 Justin Road #119-340 Flower Mound, TX 75028 Insert/edit link Close Enter the destination URL URL Link Text Open link in a new tab Or link to existing Defrian Like Show 0 Likes(0) Actions 3. Please help 0 Comment Question by:techbie Facebook Twitter LinkedIn https://www.experts-exchange.com/questions/23485906/Could-not-make-local-copy-for-file-jboss-service-xml-JBoss-error.htmlcopy LVL 4 Best Solution byMeritor can u check permissions for /home/libexec/jboss/server/default/tmp or try to delete all unnecessary content from tmp Go https://developer.jboss.org/thread/80518

The one you want is: ant clean jboss4.2 Deryk Sinotte Team Lead ICEsoft Technologies, Inc. 30/Oct/2008 12:33:57 Subject: Re:Problem icefaces with Jboss 4.2.0GA server. After the build clean it worked like magic!Before each build i deleted the output folder and there for tought that i did a fresh new build. Now that our project is nearing release, I tried to switch deploytype to ‘packaged archive'. Its happening for me in jboss-4.2.3.GA version.What might be the reason ?

do you know where ant stores previous build configurations? But JBoss server reports the error below when starting: 11:18:21,960 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resource:jboss-log4j.xml 11:18:34,801 ERROR [MainDeployer] Could not initialise deployment: file:/home/sminder/AdminUI/siteminder/adminui/server/default/deploy/iam_siteminder.ear/org.jboss.deployment.DeploymentException: No META-INF/application.xml found at org.jboss.deployment.EARDeployer.init(EARDeployer.java:146) at org.jboss.deployment.MainDeployer.init(MainDeployer.java:872) Pages: 1 Back to Thread List Legend Expert: 501 - 999999 pts Contributor: 151 - 500 pts Member: 1 - 150 pts dcm4che team community contributor Helpful Answer Correct Answer Forum Afterwards i ran the run.bat in which i also added the same JAVA_HOME and PATH settings.

judy.guglielmin Joined: 20/Feb/2007 00:00:00 Messages: 1375 Offline Looking at your stack trace, notice the following:- Code: Could not initialise deployment: file:/D:/jboss-4.2.3.GA/server/default/deploy/siigaaice.war org.jboss.deployment.DeploymentException: Failed to parse WEB-INF/web.xml; - nested throwable: (org.jboss.deployment.DeploymentException: expected When I try this I get the following error: java.io.IOException: Server returned HTTP response code: 500 for URL:

vvv Home | News | Sitemap | FAQ | advertise | its throwing following error.JAVA_HOME is not set. https://coderanch.com/t/536200/ERROR-MainDeployer-initialise-deployment-file judy.guglielmin Joined: 20/Feb/2007 00:00:00 Messages: 1375 Offline You are trying to place ICEfaces 2 application jars (which are dependent on jsf2.0) into a jboss4.2 application server (which contains jsf1.2).

Now when running C:\jboss-4.2.3.GA-jdk6\jboss-4.2.3.GA\bin\run.bat .. IoriYagami Joined: 22/Mar/2011 05:24:40 Messages: 8 Offline Hello, I have the same problem. Please turn JavaScript back on and reload this page. Unfortunately, we can't connect you to an agent.

Viewing 10 posts - 1 through 10 (of 10 total) Author Posts October 29, 2004 at 2:39 pm #218539 Reply knuterikMember When I deploy my project as an exploded archive (as http://osdir.com/ml/java.cargo.user/2007-04/msg00003.html November 3, 2004 at 3:40 am #218741 Reply knuterikMember @support-rkalla wrote: Ah ha, I think this might be it, read this thread: http://myeclipseide.com/PNphpBB2+file-viewtopic-t-3669-highlight-metainf+application+xml.html And be sure to look at the two IoriYagami Joined: 22/Mar/2011 05:24:40 Messages: 8 Offline So, I have to put IceFaces jars in the JBoss folder containing already JSF implementation. Thank you so much!

Like Show 0 Likes(0) Actions 4. http://jessriegel.com/maindeployer-could/maindeployer-could-not-create.html Like Show 0 Likes(0) Actions 13. Here is just one posting where people have listed the problems they faced doing just this:- http://community.jboss.org/wiki/upgradejbossastojsf2 Of course, the other option is to use ICEfaces 1.8.2 which works with jsf1.2 Start the server Environment: Linux 32 and 64 bit, Open JDK 1.6 file:/home/jpeterka/workspace/jbt/tc/dynweb/.metadata/.plugins/org.jboss.ide.eclipse.as.core/JBoss_EAP_4.3_Runtime_Server/deploy/DynWebEAR.ear/ No META-INF/application.xml found Manual check: application.xml really doesn't exist on the specified path JIRAs with similar problem: https://jira.jboss.org/jira/browse/JBIDE-1377

when i start it get the same error message... How Did We Do? I believe, your PATH already has a reference to the bin folder of JDK6. http://jessriegel.com/maindeployer-could/maindeployer-could-not-initialise-deployment-file.html November 2, 2004 at 9:51 am #218705 Reply knuterikMember What is strange, is that if I just zip up the exploded archive, I get the same error message, so it seems

Re: Error Could not initialise deployment jbossws.sar on run jaikiran pai Sep 15, 2008 4:07 AM (in response to Shailesh Tyagi) "Defrian" wrote:i added the following lines to the build.bat and What's the best version of JBoss I can use? As a result, the build process uses JDK6 for building the server.

at org.apache.xerces.parsers.DOMParser.parse(Unknown Source) at org.apache.xerces.jaxp.DocumentBuilderImpl.parse(Unknown Source) at org.jboss.metadata.XmlFileLoader.getDocument(XmlFileLoader.java:328) ... 23 more 17:34:48,854 INFO [EARDeployer] Init J2EE application: file:/C:/jboss-4.2.2.GA/server/default/deploy/JMSDEMOJBOSS.ear 17:34:48,854 ERROR [MainDeployer] Could not initialise deployment: file:/C:/jboss-4.2.2.GA/server/default/deploy/JMSDEMOJBOSS.ear org.jboss.deployment.DeploymentException: Invalid XML: file=META-INF/[email protected]:1; -

Covered by US Patent. but i also get the same error when i start the jdk 1.6 compiled jboss. Since the JAVA_HOME has a space in its path, that folder will be completely ignored during this check and the rest of the PATH will be checked for "java.exe". All rights reserved. {{link.title}} North America (English) Chat with CA Just give us some brief information and we'll connect you to the right CA Expert.

Going by the stacktrace, it looks like the source was built using a patch and JDK 6 and is now being run using JDK 5. Cancel Search Recent Topics Forum Home www.icesoft.org Login Problem icefaces with Jboss 4.2.0GA server. When I execute run.sh manually, I get this message: ERROR MainDeployer Could not initialise deployment: file:/Applications/dcm4chee-mysql-2.14.2/server/default/conf/jboss-service.xml org.jboss.deployment.DeploymentException: Failed to find META-INF/jboss-service.xml for archive jboss-service.xml More lines of the startup log are check my blog posted 5 years ago Remove those spaces at the beginning of line 1 of that xml file. [My Blog] [JavaRanch Journal] Post Reply Bookmark Topic Watch Topic

here's my web.xml file : Code: HelloJBossIceFaces index.html index.htm index.jsp default.html default.htm default.jsp Faces Servlet javax.faces.webapp.FacesServlet 1 We're matching your request. November 2, 2004 at 8:57 am #218700 Reply knuterikMember @support-rkalla wrote: Can you unjar the EAR file using the command line JAR utility (please don't use WinZip) and see if META-INF/application.xml Struts wizards in 3.7RC2 don't modify the struts-config.xml 1 888 914 6620 Contact Products Company Support RT @thomasfuchs: ~15 years trying to make everyone separate HTML, JS & CSS.

judy.guglielmin Joined: 20/Feb/2007 00:00:00 Messages: 1375 Offline You should probably post your stack trace. (is it exactly as the previous posting on this thread?). Also, I have been using the 5.0 release candidates with both JDK 5 and JDK 6.By the way, you should have started a new topic because you issue is not the Reply to this Thread Search Forum Back to Thread List Replies: 5 - Pages: 1 - Last Post: Jul 17, 2009 2:12 PM Last Post By: arnold wdockery Posts: 84